
      

 

  

 

Copyright 2020 by Transend Corporation 

TECHNICAL REFERENCE GUIDE 

 
 

SmartCloud Notes   →   Microsoft Office 365 

 

(Admin Authentication) 
 

 

 

 

 

 

 



 

 

EXECUTIVE SUMMARY 
 

 

 
This Technical Reference Guide provides detailed information about how to migrate 
multiple user mailboxes from SmartCloud Notes to Microsoft Office 365 using 
administrator authentication.  
  
It contains recommendations about preparing the Source and Target message 
platforms/servers to ensure the proper authentication permissions are in place, 
which eliminates the reliance on individual user ID files and passwords.  
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Section 1:  Overview 
 
This document is intended to help administrators migrate their organization’s data from 
SmartCloud Notes to Microsoft 365 using Transend Migrator.  
 
If you would like assistance planning and performing your migration, please contact Transend 
Services at services@transend.com. 
 

Terminology 
 
As we move through the example, we’ll use a few key terms that concisely describe larger 
concepts. 
 

 Migration workstation. This is a system or set of systems from which you will run the 
migration. Every migration must use at least one migration workstation. Migration 
workstations can range from your laptop to a spare computer in your datacenter to a 
dedicated virtual machine in the cloud. 
 

 Migration ID. This is the Notes ID you will use to access each user’s mail file in SmartCloud 
Notes. It can be your own admin ID file or another ID created just for the migration. 

 

 Impersonation account. This is the account you will use to access each user’s mailbox in 
Microsoft 365. This account must be given the Application_Impersonation role to all user 
mailboxes. 

 
Limitations with Encryption 

 
Because you will use a common migration ID to access user mail files, any data that has been 
encrypted by keys stored in a user’s own ID will not migrate. To migrate encrypted data, users 
must perform an end-user migration, and Transend has options to customize Transend Migrator 
to make it easier for end-users to self-migrate and capture that encrypted data.  
 

Custom Build to Support Encryption 
 
If interested, Transend is able to customize Transend Migrator for your end-user driven migration 
to capture that encrypted data. This customized version of Transend Migrator can be extremely 
easy to use for end-users, with most of the configuration information hard coded under the hood. 
It usually simply requires a few clicks by the end-users to migrate their data into their Office 365 
account.  

mailto:services@transend.com


 

2 | P a g e  
 

Prerequisites 
 
To follow along, you’ll need the following: 
 

1. A recent version of the Notes client installed on your migration workstation(s). The exact 
version isn’t important if it is at least 9.0.1 FP8. 

2. The latest version of Transend Migrator installed on your migration workstation(s). 

3. User accounts must exist in Microsoft 365. 

4. An impersonation account must be created in Microsoft 365. 

5. A list of users to migrate in CSV format, with the following format: 

a. Name 

b. Location of mail file 

c. Canonical Notes name 

d. Microsoft 365 email address 

 
The example CSV file we’ll be using looks like this: 
 

 
 
If you are using SmartCloud Notes in the Hybrid configuration, you can retrieve this information 
from your local Domino Directory. If you are using SmartCloud Notes in the Service-Only 
configuration, you’ll need to request an LDIF export of your directory data from HCL Support. 
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Section 2:  Configuration 
 
Step 1 – Configure Notes 

 
If you already have a Notes client configured to connect to SmartCloud Notes, you can skip this 
step. Otherwise, you’ll need to download the SmartCloud Notes config file from 
https://admin.notes.na.collabserv.com/liveNotes.nsf/downloadStart.xsp. Update the 
datacenter portion of the URL if required. After downloading it, open it in Notes and follow the 
prompts to join SmartCloud Notes. 
 

Step 2 – Add migration ID to user ACLs 
 
To allow your migration ID to access user mail files in SmartCloud Notes, you’ll need to run a 
batch request to add it to all ACLs. 
 

1. Log into the SmartCloud Notes Administration portal at 
https://admin.notes.na.collabserv.com/liveAdmin.nsf/home.xsp. Update the datacenter 
portion of the URL if required. 

2. Navigate to Users > Batch Request. 

3. Enter the migration ID as shown and click the Process button.  

 

4. Monitor the progress of the batch request using the Batch Request Status view. It must have 
a status of Done before you can perform the migration, but you can continue with the other 
steps below while it is in progress. 

 
  

https://admin.notes.na.collabserv.com/liveNotes.nsf/downloadStart.xsp
https://admin.notes.na.collabserv.com/liveAdmin.nsf/home.xsp
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Step 3 – Configure Transend Migrator 
 
To ensure a successful migration from SmartCloud Notes to Microsoft 365, you’ll want to 
configure some options in the Transend Migrator client.  
 

1. Open Transend Migrator. 

 
Edit License 
 

2. Choose Edit License and enter your license information. 

 
Custom Options 
 

3. Choose Migration Options > Custom Options. Use the Search field to locate and enable the 
options that follow. Note that some options have values that include $Var#. For example, 
C:\ProgramData\Transend\$Var4.dup. These are substitution variables and should be 
entered as shown. During the migration, the substitution variables are replaced by actual user 
data from the user list CSV. 

 

 General 
 Create Separate Con/Cal/Task Folders (/D219) 
 Deduping Criteria (/D56 BSDNRFHU) 
 HTTP Post Timeout (/POSTTO 5:1:3) 
 Migrate Unique Items (/DEDUP C:\ProgramData\Transend\$Var4.dup) 
 Deduping File Writes (/D165) 
 Recurring Calendar Entries (/D127) 
 Winmail.dat Parsing Off (/D148) 

 
 Filters 

 Max Attachment Size (/MAXATTACHSIZE 35000) 
 Max Message Size (/MAXMSGSIZE 150000) 
 Detach Attachments (/DETACH C:\ProgramData\Transend\$Var4) 
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 Logging/Reporting 
 Log In Text Format (/LTEXT) 
 Log Files (/LFILES) 
 Log Subjects (/LSUB) 
 Debug Logging (/DEBUG) 

 
 Exchange Web Services 

 Allow Calendar Organizer/Attendee Information (/D308 NOSTUB) 
 EWS Impersonation, Target (/AUTHEWSI2 

IMPERSONATION_ACCOUNT@YOUR_M365_DOMAIN/IMPERSONATION_ACCOUN
T_PASSWORD) 
 

 Lotus Notes 
 Appointments (/D138) 
 Decrypt Attachments (/D278) 
 Encrypted Messages (/D76) 
 Export Universal ID (/UNID) 
 Maximum Annual Occurrences (/D268 100) 
 Show Private (/SHOWPRIVATE) 
 Universal ID Logging (/D111) 
 Unread Table User (/D260 $Var3) 

 
Exclude Junk Folder 
 

4. Choose Migration Options > Folder Exclude List.  

Add the Junk folder as shown: 
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Folder Mapping 
 

5. Choose Migration Options > Folder Mapping.  

Add the folder mappings as shown:  
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Address Translation 
 

6. Choose Migration Options > Address Translation.  

Address translation is a critical component of a migration from SmartCloud Notes because 
Notes addresses cannot be processed by Microsoft 365. The screenshot below shows the 
main formats you’ll encounter in Notes. You’ll need to add each format for every user. If 
adding these for each user is not feasible, you have two options: 

a. Add as many formats as you can, understanding that formats that are not added to 
the table will not be converted during the migration. This may result in some 
messages not being routable in Microsoft 365. 

b. Contact Transend Services for help in building a translation table.  
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Configure Main Interface 
 

7. From the main screen of the Transend Migration client, click E-Mail and enter the information 
as shown, replacing the Password field with your migration ID password and ID path. Note 
that this field expects data in PASSWORD;USERID format. Repeat for Address Book, Calendar 
and Task/To Do.  

Email configuration: 

 
 

Address Book configuration: 
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Calendar configuration: 

 
 

Tasks/To Do configuration: 

 

 

8. Click File > Save Configuration and restart Transend Migrator. 
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Step 4 – Import users from CSV 

The final step before running the migration is to load the users from the CSV file into Transend Migrator. 
 
When migrating on a single Workstation 

If you are migrating all users from a single migration workstation, you can load the entire CSV 
and do not need to worry about which migration workstation a user has been assigned to, since 
there is only one. 

 
When migrating on multiple Workstations 

If you are migrating users from multiple migration workstations, each user must be assigned to 
a single migration workstation for the lifetime of the project because artifacts pertaining to 
each user’s migration will only exist on the migration workstation that processes that user. This 
is particularly important for the deduplication file that prevents multiple runs from migrating 
previously migrated messages. If the deduplication file is on Workstation A but the user has a re-
run on Workstation B, all the user’s data will be re-migrated because Workstation B does not 
have that user’s deduplication file. 

 

1. Choose Batch Migration > Batch Migration Setup. 

2. Click the Load From File button and select the user list CSV. 

 

 

Step 5 – Start migration 

To start the migration, click Start Batch Migration from the main screen of the Transend Migrator 
client. 
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Section 3:  Technical Support 
 
Technical support is available to help you understand how to use Transend Migrator with your migration 
project. Please review the Help File and online resources before contacting technical support. 
 
You are encouraged to submit questions through email. This will allow us time to properly research your 
situation and make appropriate recommendations. 
 
Note: Transend’s normal business hours are M-F, 9am – 5pm (Pacific). If you will be performing a 
migration during non-business hours, and anticipate a need for support during non-business hours, please 
contact us at least 7 days in advance so we can schedule a support engineer to be available, if possible. 
 
Sending Log Files to Transend Technical Support 
 
It is important to include a copy of your log files when submitting a support request. You may send the 
log files individually, or send the log files using the Email Log Files menu feature from the Transend 
Migrator interface using the following procedures: 
 

 
 
Select Help>Email Log Files from the menu list. Transend Migrator will attempt to open your default email 
program and then create a new message similar to the example, below. 
 

 
 
Notice 
The path to the log file package (a zip file containing your log files, report, and settings file) will be inserted 
into the body of the email message. In the example, the log file path and filename is at 
C:\Users\john.hieb\Documents\Transend_Logfiles.zip. Your path will be similar. Using your email 
program, insert the log file package. Use the path and filename listed in your email message.  
 
Before contacting technical support, we recommend that you are using the current patches or service 
packs for your hardware, your operating system and software. Also, download the latest version of 
Transend Migrator from www.transend.com. Review the What’s New section of the Transend web site to 
review the latest release information. 
 
Email:   tech.support@transend.com. 
Phone: (650) 324-5370 

http://www.transend.com/
http://www.transend.com/whats_new.asp
mailto:tech.support@transend.com?subject=Transend%20Migrator%20Technical%20Support%20Request

